db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig L Russell <Craig.Russ...@Sun.COM>
Subject Re: JDK level support in JDO
Date Mon, 18 Aug 2008 15:32:06 GMT
Hi Andy,

On Aug 18, 2008, at 7:41 AM, Andy Jefferson wrote:

> Hi,
>
> all previous JDO releases have always supported JDKs 1.3 and above.
> JDO2.1 started providing the "api2-legacy" for JDK1.3/4, and "api2"  
> for
> JDK1.5+ specifics.
>
> Just a note about DataNucleus AccessPlatform support levels.
> 1. AccessPlatform 1.0 will be the last release that will support  
> JDK1.3/1.4.
> 2. AccessPlatform 1.1 will support JDK1.5+ only.
>
> AccessPlatform 1.0 will be branched at its 1.0 final release (start  
> of Sept)
> and there could be minor releases on that branch after this point,  
> but we
> just don't have the resources to support 2 branches for any period.
>
>
> What are the Apache JDO timescales for dropping support for  
> JDK1.3/1.4 ?
> Perhaps make JDO2.2 the final release supporting JDK1.3/1.4?

I'd be happy with either JDO 2.1 or JDO 2.2 being the last release to  
support the legacy JVMs. Subject to the community, of course (and  
subject to people to do the work).

There's real work in migrating the 2.2 work done so far to the 2.1  
platform, and I'd be happy to help a volunteer to do it. Not so keen  
on doing all the work myself.

Craig
>
>
>
>
> -- 
> Andy  (DataNucleus - http://www.datanucleus.org)

Craig L Russell
Architect, Sun Java Enterprise System http://java.sun.com/products/jdo
408 276-5638 mailto:Craig.Russell@sun.com
P.S. A good JDO? O, Gasp!


Mime
View raw message