db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Bouschen (JIRA)" <j...@apache.org>
Subject [jira] Updated: (JDO-477) JDOHelperConfigTest fails on non-JDK 1.4 JVMs
Date Fri, 13 Apr 2007 17:07:16 GMT

     [ https://issues.apache.org/jira/browse/JDO-477?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Bouschen updated JDO-477:
---------------------------------

    Attachment: JDO-477-mbo-2007-04-13.patch

Please review the attached patch JDO-477-mbo-2007-04-13.patch. It removes the dependency to
an explicit xerces version which seems to cause the LinkageError. 

With this patch running the tests with JDK 1.5 succeed. However, you see some messages printed
during test runs ([Fatal Error] :-1:-1: Premature end of file). Fixing these is not part of
this patch.

> JDOHelperConfigTest fails on non-JDK 1.4 JVMs
> ---------------------------------------------
>
>                 Key: JDO-477
>                 URL: https://issues.apache.org/jira/browse/JDO-477
>             Project: JDO
>          Issue Type: Bug
>          Components: api2
>    Affects Versions: JDO 2 maintenance release 1
>         Environment: JDK 1.5 & 1.6
>            Reporter: Matthew T. Adams
>         Assigned To: Michael Bouschen
>         Attachments: JDO-477-mbo-2007-04-13.patch, JDO-477.2007-04-06.patch
>
>
> On JDK 1.5, java.lang.LinkageErrors are thrown attempting to load org.w3c.dom.Node.class.
> On JDK 1.6, positive test cases fail unexpectedly.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message