db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig Russell (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JDO-309) minor extensions to tck20's JDO_Test and ThreadExceptionHandler
Date Sat, 18 Feb 2006 21:18:25 GMT
    [ http://issues.apache.org/jira/browse/JDO-309?page=comments#action_12366922 ] 

Craig Russell commented on JDO-309:

Looks good. Just a comment.

1. Please change name of popMessages to something else. Pop has a specific meaning (remove
the top element of a Stack) and I don't think it's appropriate for a Message pad.

How about:

String retrieveMessages() that has the same semantics as your popMessages.

> minor extensions to tck20's JDO_Test and ThreadExceptionHandler
> ---------------------------------------------------------------
>          Key: JDO-309
>          URL: http://issues.apache.org/jira/browse/JDO-309
>      Project: JDO
>         Type: New Feature
>   Components: tck20
>     Reporter: Martin Zaun
>     Priority: Trivial

> JDO_Test should be extended for methods collection error messages.
> ThreadExceptionHandler should be extended for clearing stored exceptions.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message