db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig Russell (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JDO-313) ERROR 08001: No suitable driver on connection attempt to install schema
Date Thu, 23 Feb 2006 18:56:37 GMT
    [ http://issues.apache.org/jira/browse/JDO-313?page=comments#action_12367561 ] 

Craig Russell commented on JDO-313:
-----------------------------------

The dependency in rc1 hasn't changed. In the project.xml for both the trunk and branches/2.0-rc1:

        <dependency>
            <groupId>org.apache.derby</groupId>
            <artifactId>derby</artifactId>
            <version>10.1.1.0</version>
        </dependency>
        <dependency>
            <groupId>org.apache.derby</groupId>
            <artifactId>derbytools</artifactId>
            <version>10.1.1.0</version>
        </dependency>

It works fine for me.

Did the maven build download the derby jars?


> ERROR 08001: No suitable driver on connection attempt to install schema
> -----------------------------------------------------------------------
>
>          Key: JDO-313
>          URL: http://issues.apache.org/jira/browse/JDO-313
>      Project: JDO
>         Type: Bug
>   Components: tck20
>     Versions: JDO 2 rc1
>     Reporter: Michelle Caisse
>      Fix For: JDO 2 rc1

>
> I moved my old local maven repository to test that all the automatic downloads work properly.
The build failed on schema installation with a "No suitable driver" message. As we formerly
had the derby jars in a directory called derby in the local maven repository, then changed
it to org.apache.derby, perhaps some dependency on the old location remains in maven.xml.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message