db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Zaun <Martin.Z...@Sun.COM>
Subject current tck11 fails with jdk 1.5 despite maven.compile.target=1.3
Date Fri, 04 Nov 2005 04:52:47 GMT

A final test on a clean workspace revealed an issue with
the current build scripts for ri/tck11, which we might
want to fix before I check in the enhancer support for
jdk 1.5 classfiles.

Even if the jdo/trunk/project.properties file has correct
settings:
   # Make sure the compiled class still work with J2SE 1.3
   maven.compile.source = 1.3
   maven.compile.target = 1.3
the tck11 (not the ri11 junit tests) tests fail during
enhancement when JAVA_HOME points to jdk 1.5, because of
current lack of support for jdk 1.5 classfiles:
     [java] org.apache.jdo.impl.enhancer.EnhancerUserException: I/O error while r
eading input stream or input stream does not denote a valid Java class.
     [java] CauseThrowable:
     [java] java.lang.ClassFormatError: Bad version number: {49,0} expected one o
f: {{45,3}{46,0}{47,0}{48,0}}
     [java] aborted with errors.

Apparently, the source/target properties are not properly
being used when compiling the PC/PA classes for the tck11.

So, the status as of now is that one cannot have JAVA_HOME
set to jdk 1.5 for building tck11.

Of course, this bug would go away with the new 1.5
classfile support, but I guess we'd like to fix that the
source/target properties are not properly adhered to.

What's strange, I tested adding the above properties to
the project.properties file in ri11 and tck11, and ran
from the trunk
   maven jdo11.clean jdo11.build
and tck11 still fails with the same error, though I
thought I had this going before.

I've tried to understand the maven scripts a bit with
regard to where which properties are being used, but with
not much success.

Michael, any idea?

Thx,
Martin

Mime
View raw message