db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Bouschen <mbo.t...@spree.de>
Subject Re: build failed
Date Sat, 22 Oct 2005 18:10:51 GMT
Hi,

I found the following message talink about cleaning up ibiblio:
  http://www.mail-archive.com/dev@maven.apache.org/msg39867.html
It lists files in ibiblio that are not in the maven staging repository 
at codehaus. This list includes antlr-2.7.5.jar.

Regards Michael

> Hi Karan,
>
> this is really strange! In August I changed the dependency from 
> antlr-2.7.3 to antlr-2.7.5, because 2.7.5 was available on ibiblio, 
> but not version 2.7.3. I'm surprised because I thought once a version 
> is on ibiblio it will never be removed.
>
> I never tested with version 2.7.4, but I know that we need at least 
> 2.7.3, because there are problems with the generated lexer when using 
> 2.7.2 or earlier. We should try to find out why version 2.7.5 
> disappeared from ibiblio before we change the dependency.
>
> For now I propose you download antlr-2.7.5.jar directly from 
> http://www.antlr.org/download.html and store in in your local repository.
>
> Regards Michael
>
>> Hi,
>>
>> Tried to do maven jdo11.build and got the following error:
>>
>> BUILD FAILED
>> File...... /home/karan/.maven/cache/maven-multiproject-plugin-1.3.1
>> /plugin.jelly
>> Element... maven:reactor
>> Line...... 217
>> Column.... 9
>> The build cannot continue because of the following unsatisfied 
>> dependency:
>>
>> antlr-2.7.5.jar (try downloading from 
>> http://www.antlr.org/download.html)
>>
>>
>> I looked up the project.xml files of jdo11 projects and found a 
>> reference to
>> antlr2.7.5. Now, Ibiblio does not host 2.7.5 version, which means 
>> that we
>> need to explicitly download this file or do we need to add another 
>> remote
>> repository to our path which points to antlr 2.7.5. I know that there 
>> was
>> some issue regarding antlr2.7.5 earlier also, but cannot remember what
>> exactly was the issue and the solution to it.
>>
>> But do we really need antlr2.7.5. Ibiblio is currently hosting the 
>> following
>> jar files:
>>
>> antlr-2.7.2.jar
>> antlrall-2.7.4.jar
>>
>> If 2.7.5 is not needed then i can submit a patch and fix this issue (i
>> thought this thing was fixed earlier).
>>
>> -- 
>> Karan Malhi
>>
>>  
>>
>
>


-- 
Michael Bouschen		Tech@Spree Engineering GmbH
mailto:mbo.tech@spree.de	http://www.tech.spree.de/
Tel.:++49/30/235 520-33		Buelowstr. 66			
Fax.:++49/30/2175 2012		D-10783 Berlin			


Mime
View raw message