db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig Russell <craig.russ...@sun.com>
Subject Subject: JDORI and jdk1.5
Date Wed, 28 Sep 2005 22:37:10 GMT
Hi Charles,

JDO is now an open source project at Apache.
http://wiki.apache.org/jdo. We are aware of the issues with JDK 1.5
and are working on the problem. The intent is to support JDK 1.5 for
both JDO 1.1 (the updated Apache JDO 1) and JDO 2.0.

Craig

Hi JDO experts,

Question 1:

When I compile the enhancer files undet jdk 1.5 I got the following errors:
+++++++++++++++++++++++++++++++++++++++++++++
[java] Error while enhancing: JDO ENHANCER: At least one error occurred
while enhancing input class for Transparent Persistence; detailed
message(s): I/O error while reading input stream or input stream does
not denote a valid Java class.
[java] com.sun.jdori.enhancer.EnhancerUserException: JDO ENHANCER: At
least one error occurred while enhancing input class for Transparent
Persistence; detailed message(s): I/O error while reading input stream
or input stream does not
denote a valid Java class.
[java]	at
com.sun.jdori.enhancer.filter.Enhancer.enhanceClassFile(Unknown Source)
[java]	at com.sun.jdori.enhancer.Main.enhanceClassFile(Unknown Source)
[java]	at com.sun.jdori.enhancer.Main.enhanceInputFiles(Unknown
Source)	[java]	at com.sun.jdori.enhancer.Main.process(Unknown Source)
[java]	at com.sun.jdori.enhancer.Main.main(Unknown Source)
++++++++++++++++++++++++++++++++++++++++++++++

Do we have plan to make JDO 1.0.1 be jdk 1.5 compatible?

Question 2: Are we going to support JDO 2.0?  Is JDO 2.0 compatible with
jdk1.5?

Thanks
Charles Ting
X20170

Mime
View raw message