db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig Russell <Craig.Russ...@Sun.COM>
Subject Re: Patch for project.xml
Date Sun, 07 Aug 2005 18:52:58 GMT
Hi Niclas,

On Aug 7, 2005, at 5:57 AM, Niclas Hedhman wrote:

> On Sunday 07 August 2005 20:43, Karan Malhi wrote:
>
>> 1. Does this project depend on 2.7.3 or can we move to 2.7.4 or  
>> 2.7.2. If
>> yes, then this will allow us to set maven to automatically  
>> download antlr.
>>
>
> Someone wrote that the ANTLR version being dependent upon is  
> custom, but the
> version numbering doesn't indicate anything special, so perhaps it  
> is just a
> "pre-built" with features coming into later versions.

The reason we use 2.7.3 is that there are some "hand-crafted" pieces  
of our .g files that support international characters in a way that  
is not standard, so we need to adapt it for each new release of  
ANTLR. We're hoping that the international support in ANTLR can  
eventually allow us to drop the special stuff and we can go with the  
latest.

I think Brian tried 2.7.5 but it didn't work so we need to look at it  
more.

Craig

> Cheers
> Niclas
>

Craig Russell
Architect, Sun Java Enterprise System http://java.sun.com/products/jdo
408 276-5638 mailto:Craig.Russell@sun.com
P.S. A good JDO? O, Gasp!


Mime
View raw message