db-jdo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Jefferson <a...@jpox.org>
Subject Re: JDO-61
Date Thu, 09 Jun 2005 17:25:09 GMT
> Is there anything in cvs but not in the latest build that would cause
> this test to pass?
>
> Are you running with the same jdo properties that we do (checked into
> test/conf)?

What I use is :-
Apache JDO : SVN
JPOX : CVS

I changed a few things in extent handling this morning but nothing of 
significance that would affect the creation of the SELECT for the iterator.

What I run is :-
maven clean database -Dtest=extents.InstancesPersistedPriorToIterationReturned 
runtck.single


runtck.single:
    [echo] Run TCK test 
org.apache.jdo.tck.extents.InstancesPersistedPriorToIterationReturned on the 
IUT with 
configuration /home/andy/work/jdo/trunk/tck20/test/conf/datastoreidentity.conf
    [java] RUN InstancesPersistedPriorToIterationReturned.test
    [java] Time: 26.204
    [java] OK (1 test)


If you wish to investigate the issue you could just look in the JPOX log. The 
only issue is the ordering of the INSERT (of the additional object) and the 
SELECT (for the Extent). I get the INSERT before the SELECT when I run as 
above.


-- 
Andy
Java Persistent Objects JDO - JPOX

Mime
View raw message