db-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michelle Caisse <Michelle.Cai...@Sun.COM>
Subject Re: maven problems building site
Date Mon, 01 Oct 2007 18:10:11 GMT
Thanks very much, Knut Anders, works great now, except...

Now I'm having trouble deploying. Deployment seems to hang after 
building the site archive and deleting the old tar file. The readme 
doesn't mention checking in the changes to svn. Does site:deploy handle 
that automatically? Can I work around the deployment issue by checking 
in my changes, ssh'ing to people.apache.org, and doing an 'svn update' 
and 'maven site' there?

-- Michelle

Knut Anders Hatlen wrote:

>Michelle Caisse <Michelle.Caisse@Sun.COM> writes:
>
>  
>
>>Hi,
>>
>>I'm trying to build the db site, running maven 1.0.2. maven was unable
>>to download the dependencies. Possibly a temporary problem with the
>>maven download site?? Anyway, after manually downloading the
>>dependencies and their dependencies and placing them in my local
>>repository, I'm left with one unresolved dependency:
>>
>>Attempting to download js-1.5R4-RC3.jar.
>>Error retrieving artifact from
>>[http://www.ibiblio.org/maven/rhino/jars/js-1.5R4
>>-RC3.jar]: java.io.IOException: Unknown error downloading; status code
>>was: 301
>>WARNING: Failed to download js-1.5R4-RC3.jar.
>>
>>BUILD FAILED
>>File...... c:\home\.maven\cache\maven-xdoc-plugin-1.8\plugin.jelly
>>Element... attainGoal
>>Line...... 657
>>Column.... 46
>>The build cannot continue because of the following unsatisfied dependency:
>>
>>js-1.5R4-RC3.jar
>>
>>I've downloaded this manually also and placed it in
>>.maven/repository/js/jars, but, still the error.
>>
>>Any ideas?
>>    
>>
>
>I found this at http://maven.apache.org/maven-1.x/news.html:
>
>  
>
>>7 December 2006 - Central repository isn't working for maven 1.0.x users
>>
>>   If you are using Maven 1.0.x you may have found that the repository
>>   is not working and Maven is unable to download new
>>   dependencies. The reason is that the ibiblio guys have moved the
>>   repo to another machine and Maven 1.0.x can't handle redirects
>>   across different host names.
>>
>>   The workaround is to use the new central repository configuration
>>   until ibiblio fixes the problem. Add to your project.properties :
>>
>>   maven.repo.remote=http://repo1.maven.org/maven
>>    
>>
>
>The workaround worked for me, so I checked it in with revision
>580588. Please do an svn update and try again.
>
>  
>


Mime
View raw message