db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Katherine Marsden <kmarsdende...@sbcglobal.net>
Subject Re: Strange situation
Date Tue, 13 Aug 2013 17:29:51 GMT
On 8/13/2013 7:37 AM, Carlos de Luna Saenz wrote:
>
> We have a stange behavour in a database that is "imported" from a SQL 
> Server DB.
>
> On Windows Derby shows all records fine, but when used as "read only" 
> (root admin owned with 755) on Mac there is a table that shows as 
> empty (0 records) when the same DB in Windows has 1310 records.
>
> for accessing the DB we are using the Emmbeded driver...
>
> We found that the first time the DB is used on Mac or windows there 
> are some files changes (if 777 is set as permissions) and then the 
> records are shown, but the installation program is not seting (and we 
> don't want) those priviledges to the derby files...
>
> Any idea on WHY this is happenning? we are looking how to get files 
> that works with the install but we would like to know what do we have 
> to be aware to prevent this "data lose" when copying the DB.
>
> Greetings
>
My guess is that you did not shutdown the database before deploying read 
only.  See this information for preparing a database for read-only use:
http://db.apache.org/derby/docs/10.10/devguide/tdevdeploy26887.html

> *Ing. Carlos de Luna Sáenz *| Dirección de Sistematización de Tesis - 
> Director de Área |
>
> Dirección General de Tecnologías de la Información | *Suprema Corte de 
> Justicia de la Nación*
>
> T. +52.55. 4113-1000 ext. 1174 | C: cluna@scjn.gob.mx 
> <mailto:cluna@scjn.gob.mx>
>


Mime
View raw message