db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James B. Millard" <...@jbmballistics.com>
Subject Boolean in version 10.9
Date Sat, 15 Dec 2012 22:18:39 GMT
I've been using derby on windows for a few weeks and decided to move my
development to Linux (Fedora 14).  

I have database creation scripts that I'm trying to run but I'm getting the
following error:

ij> CREATE TABLE COMPONENT_PROPERTIES
        ( ID INTEGER NOT NULL GENERATED ALWAYS AS IDENTITY (START WITH 1,
INCREMENT BY 1),
	  COMPONENT_CLASS 	VARCHAR(48),
	  PROPERTY_SHORT_NAME 	VARCHAR(48),
	  PROPERTY_LONG_NAME 	VARCHAR(64),
	  PROPERTY_CLASS 	VARCHAR(48),
	  PROPERTY_FORMAT_CLASS VARCHAR(48),
	  PROPERTY_FORMAT_DATA  VARCHAR(48),
	  PROPERTY_READ_ONLY 	BOOLEAN,
	  PROPERTY_EDIT_CREATE 	BOOLEAN,
	  PROPERTY_PERIOD 	BOOLEAN,
	  PROPERTY_TO_DATE 	BOOLEAN,
	  PROPERTY_DISPLAY 	BOOLEAN,
	  PROPERTY_CATEGORY 	VARCHAR(16) );
ERROR XCL47: Use of 'BOOLEAN' requires database to be upgraded from version
10.5 to version 10.7 or later.

This seems odd since I'm running 10.9 and these same scripts worked under
Windows with the same version of derby.

Here's what I see when I start ij:

[jbm@hk sql]$ ij
ij version 10.9
ij> 


Thanks!

Brad





--
View this message in context: http://apache-database.10148.n7.nabble.com/Boolean-in-version-10-9-tp125847.html
Sent from the Apache Derby Users mailing list archive at Nabble.com.

Mime
View raw message