db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From istanbullu <yuksel.gu...@gmail.com>
Subject Rollforward recovery problem
Date Wed, 05 Sep 2012 20:44:38 GMT

Hi,

I have a script that does rollforward recovery, but recovery does not appear
to be working in a particular scenario. 

Let me first describe a test scenario that works:

1) I take a DB back-up by enabling log archive mode
2) I delete all files under seg0 directory of the original DB
3) Then, I run my rollforward recovery script, and I see the DB restored
from the backed-up DB created in step 1.  I run consistency check and I see
no issues in the restored DB.

Now, here is the failing scenario:

1) I take a DB back-up by enabling log archive mode
2) I delete a subset of files under seg0 directory of the original DB (say
c5*.dat)
3) Then, I run rollforward recovery script, and I DO NOT see the deleted
files restored from the backed-up DB created in step 1.  I run consistency
check and it fails.

Note that the only difference is that in successful scenario all files under
seg0 are deleted.

My scripts are along the lines of code snippets discussed in this
developerworks article:

http://www.ibm.com/developerworks/data/library/techarticle/dm-0502thalamati/index.html
http://www.ibm.com/developerworks/data/library/techarticle/dm-0502thalamati/index.html 

Any comments appreciated.

-- 
View this message in context: http://old.nabble.com/Rollforward-recovery-problem-tp34394515p34394515.html
Sent from the Apache Derby Users mailing list archive at Nabble.com.


Mime
View raw message