db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John I. Moore, Jr." <softmo...@att.net>
Subject RE: Derby Incompatible with "Substituted" Drives on Windows
Date Tue, 31 Jul 2012 11:29:38 GMT
Since I was able to solve the problem using a different approach, I did not save all the old
log file or error messages, but here is some additional information.
When I tried to connect to the database with the usual URL similar to
     jdbc:derby://localhost:1527/K:\\ MyDB
it failed to connect, but when I used the real path name and not the substituted name similar
everything worked as expected.
The problem occurred in Windows Server 2008, 64-bit.
I suspect that the problem is easily duplicated, but if you can't, I can try to find the time
duplicate it and send you the error messages.
From: Kristian Waagan [mailto:kristian.waagan@oracle.com] 
Sent: Tuesday, July 31, 2012 6:41 AM
To: derby-user@db.apache.org
Subject: Re: Derby Incompatible with "Substituted" Drives on Windows
On 31.07.2012 12:32, John I. Moore, Jr. wrote: 
Derby Users and Developers,
I have an application that has used Derby (with the Network Server) for years, and overall
I have
been extremely pleased.  However, I ran into a problem when trying to upgrade to
I have three computing environments that I work in, which can be thought of a development,
test, and
production.  For reasons not worth the trouble of explaining, these three environments are
different, but until the latest release of Derby I could make them appear to be very similar
by the
use of the Windows "subst" command, which associates a path with a drive letter.  For example,
command "subst K: C:\SomeDir" makes the system appear to have a "K" drive, which in reality
simply mapped to the directory SomeDir on the C drive.  All previous versions of Derby handled
databases on this substituted K drive without any problems, but version breaks on
it.  I
was able to get around this problem by setting up a virtual drive using a different approach,
so now
I have been able to upgrade Derby, but I wanted to point out the problem is case others have
encountered it.

Hi John,

Do you have any more information about what breaks?
I.e., are you able to boot the database?
Do you get an error message?
On which versions of Windows have you observed the problem?


John Moore

View raw message