My manifest :


Manifest-Version: 1.0

Main-Class: Main

Class-Path: SimulProg\lib\tinylaf.jar SimulProg\lib\swing-layout-1.0.3.jar SimulProg\lib\swt.jar SimulProg\lib\grouplayout.jar SimulProg\lib\resources.jar SimulProg\lib\rt.jar \

 SimulProg\lib\RXTXcomm.jar SimulProg\lib\ SimulProg\lib\ \

 SimulProg\lib\derby.jar SimulProg\lib\derbyclient.jar SimulProg\lib\derbynet.jar SimulProg\lib\derbytools.jar SimulProg\lib\derbyrun.jar \

 SimulProg\lib\jsse.jar SimulProg\lib\jce.jar SimulProg\lib\sunjce_provider.jar SimulProg\lib\sunmscapi.jar \

 SimulProg\lib\charsets.jar SimulProg\lib\dnsns.jar SimulProg\lib\localedata.jar SimulProg\lib\sunpkcs11.jar





De : Marco Ferretti []
Envoyé : jeudi 21 juin 2012 14:58
À : Derby Discussion
Objet : Re: Correct Derby software ?


You need to have the jars in the classpath : either define it with startup params of your application, put them in the jdk/jre's default classpath, in the classpath defined in the machine or in the manifest file of your jar (

On Thu, Jun 21, 2012 at 1:54 PM, Isabelle DASTUGUE <> wrote:


I have a Derby database that works when I start it from Eclipse, but when I try to run it from the. Jar of my application, it does not work.

Here are two successive errors:
java.sql.SQLException: Failed to start database 'C:\Test\Base' with class loader sun.misc.Launcher$AppClassLoader@35ce36, see the next exception for details.
Caused by: java.sql.SQLException: Startup failed due to missing functionality for Please ensure your classpath includes the correct Derby software.

I put the Derby access to my files in the classpath in environment variables, but it's still not working.

My four files:
- Derby.jar,
- Derbyclient.jar,
- Derbynet.jar,
- Derbytools.jar.
Are exactly the same and on the same PC ...

Without the call to the base, my. Jar works.
With the base, I create the server, do I start Derby, I run the instance but I cannot connect to the database at the address returned is obviously good ...

Any idea?






"No Im sorrys, no apologies, no regrets..... "