db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Isabelle DASTUGUE" <isabelle.dastu...@SELA-LIGHT.com>
Subject Operation 'next' not permitted
Date Mon, 20 Feb 2012 14:19:12 GMT
Hello,

I am facing a problem with the commit: « java.sql.SQLException: ResultSet not open. Operation
'next' not permitted. Verify that autocommit is OFF. »
I found this documentation : https://issues.apache.org/jira/browse/DERBY-4095?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#issue-tabs
So I tried to update Derby in Eclipse.
Here is the information sent by Derby (Sysinfo):
--------- Derby Information --------
JRE - JDBC: Java SE 6 - JDBC 4.0
[C:\Program Files\eclipse\plugins\org.apache.derby.core_10.8.1\derby.jar] 10.8.1.2 - (1095077)
[C:\Program Files\eclipse\plugins\org.apache.derby.core_10.8.1\derbytools.jar] 10.8.1.2 -
(1095077)
[C:\Program Files\eclipse\plugins\org.apache.derby.core_10.8.1\derbynet.jar] 10.8.1.2 - (1095077)
[C:\Program Files\eclipse\plugins\org.apache.derby.core_10.8.1\derbyclient.jar] 10.8.1.2 -
(1095077)

But now I've always the error, what can I do ?

Thank you in advance

Isabelle


//----------------------------------------------------------------------------------------------------------

Bonjour,

Je suis confrontée à un problème avec le commit : « java.sql.SQLException: ResultSet not
open. Operation 'next' not permitted. Verify that autocommit is OFF. »
J'ai trouvé cette documentation : https://issues.apache.org/jira/browse/DERBY-4095?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#issue-tabs
J'ai donc tenté de mettre à jour Derby dans Eclipse.
Voici les information Derby envoyées par Sysinfo :

--------- Derby Information --------
JRE - JDBC: Java SE 6 - JDBC 4.0
[C:\Program Files\eclipse\plugins\org.apache.derby.core_10.8.1\derby.jar] 10.8.1.2 - (1095077)
[C:\Program Files\eclipse\plugins\org.apache.derby.core_10.8.1\derbytools.jar] 10.8.1.2 -
(1095077)
[C:\Program Files\eclipse\plugins\org.apache.derby.core_10.8.1\derbynet.jar] 10.8.1.2 - (1095077)
[C:\Program Files\eclipse\plugins\org.apache.derby.core_10.8.1\derbyclient.jar] 10.8.1.2 -
(1095077)

Mais actuellement j'ai toujours l'erreur, que puis je faire de plus ?

Merci par avance

Isabelle



Mime
View raw message