db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <rick.hille...@oracle.com>
Subject [NOTICE] Eclipse plugins will be removed from Derby
Date Mon, 13 Jun 2011 19:46:14 GMT
Resending this message under another subject line. If no-one volunteers 
to build and host these plugins, they will not be available after 
release 10.8.2.

Regards,
-Rick

On 5/26/11 7:40 AM, Rick Hillegas wrote:
> Dear Eclipse users,
>
> For the past six years, Derby releases have included two Eclipse 
> plugins: a core plugin and a ui/doc plugin. The Derby developers have 
> come to the conclusion that these plugin artifacts fall outside the 
> scope of our charter, which explictly excludes IDE and GUI work: 
> http://db.apache.org/derby/derby_charter.html#Database+Technology For 
> future releases, we would like to get out of the business of producing 
> these plugins. We plan to build them for one more maintenance release, 
> 10.8.2: http://wiki.apache.org/db-derby/DerbyTenEightTwoRelease After 
> that, we need to find some other way to support people who develop 
> Derby-powered applications with Eclipse.
>
> We have two immediate questions for Eclipse users:
>
> 1) Does anyone use these plugins anymore?
>
> 2) Would someone in the user community be willing to build these 
> plugins for each Derby release and host them someplace else, perhaps 
> at http://marketplace.eclipse.org/ ?
>
> Thanks,
> -Rick
>
>


Mime
View raw message