db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas <Thomas.K.H...@t-online.de>
Subject Re: Trying to migrate to LDAP (but getting Error 08004)
Date Mon, 17 Jan 2011 19:47:20 GMT
Bryan,

thanks for your answers and suggestions. My updates are as follow:

1) derby.log does not contain any information other than the server having 
been started
2) I added 'ldap:://' at the start and '/' at the end of the value for 
property derby.authentication.server and (after having dropped and 
recreated the whole data base) retested still using the network client
driver - no difference, i.e. still receiving the same error
3) I then used the embedded driver and recreated the database from scratch
once again - and found everything working as expected with this driver! 
So using correct credentials I could connect to the data base and select 
data, providing incorrect user name and/or password resulted in the error
08004 with the message 'invalid athentication..'. Hard to believe that 
the network client driver is not working, whereas the embedded driver does!?
-> where the normal use case I would consider using LDAP only in multi-user/
networked environments (and with all the warnings about the BUILTIN security
system and the advise to use LDAP I would have expected quite some people 
having switched and then run into this problem??).

Can you please advise on next steps?, i.e. should I create a JIRA issue
immediately or will/should someone from the development try to reproduce 
first?

Regards
Thomas




Mime
View raw message