Windows uses the semicolon, not the colon, to separate files/paths for the classpath.  So it should read:

java -classpath /home/user/app/lib/derbyrun.jar;/home/user/app/shared/
-Dtmp.policy=/home/user/app/server/tmp/group.policy tmp.Setup

I'm also not sure that derbyrun.jar is the only derby file you need?  Though I get my jars through maven so I don't know whether direct downloads are named differently or if you renamed anything.  Also, you shouldn't need a leading colon/semicolon.


On Wed, Dec 1, 2010 at 6:13 AM, BeNdErR <> wrote:

thanks everyone for your reply.

The wildcard is recognised by the shell (echo /path/* works, showing all the
files in the directory) but as Ron said, I can't use wildcards for
I tryed changing "/*" with "/derbyrun.jar" but nothing new happened, same
error shows


reading the last link you posted, about classpath usage, I had some doubts
about my server startup, so here is the entire command I run for the server:

java -classpath :/home/user/app/lib/derbyrun.jar:/home/user/app/shared/
-Dtmp.policy=/home/user/app/server/tmp/group.policy tmp.Setup

my doubt is on this part of "Setting the class path" link, maybe because I
read the windows version and not the linux one :D

C:> java -classpath C:\java\MyClasses utility.myapp.Cool

When the app runs, the JVM uses the class path settings to find any other
classes defined in the utility.myapp package that are used by the Cool

as you can see I run the server setup in the tmp package. Reading the
article mentioned before, what I understood is that all the classes my Setup
needs are searched in the classpath linked by the command, but in a tmp
folder. Am I wrong?

thanks (hope you understand my english-way-to-explain)

View this message in context:
Sent from the Apache Derby Users mailing list archive at