db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristian Waagan <kristian.waa...@oracle.com>
Subject Re: Derby : No suitable driver found for jdbc:derby:db;create=true
Date Wed, 01 Dec 2010 20:57:39 GMT
On01.12.2010 19:45, BeNdErR wrote:
> @bryan
> I tryed to run ij instead of tmp.Setup, as you said, then I tryed to connect
> to a new db, that's what I got:
>
> ij>  CONNECT 'ciao;create=true';
> ERRORE 08001: No suitable driver found for ciao;create=true

Note that unless you have configured Derby to use a specific protocol 
(impossible to say based on the output above), the connection URL has to 
be 'jdbc:derby:ciao;create=true'.
ij is a rather general tool, and you could use it to connect to another 
database, in which case 'derby' would have to be replaced and maybe that 
driver would need different connection attributed.

Another example is if you want to use the in-memory back end with Derby, 
in which case the URL would be something like 
'jdbc:derby:memory;ciao;create=true';


Regards,
-- 
Kristian

> ij>
>
>
> so something is still wrong :\
>
> running org.apache.derby.tools.sysinfo I have:
>
>
> ------------------ Informazioni su Java ------------------
> Versione Java:   1.6.0_22
> Fornitore Java:  Sun Microsystems Inc.
> Home Java:       /usr/lib/jvm/java-6-sun-1.6.0.22/jre
> Percorso classi Java:
> /home/user/app/lib/derby.jar:.:/home/user/app/lib/derbytools.jar:.
> Nome SO:         Linux
> Architettura SO: i386
> Versione SO:     2.6.35-23-generic
> Nome utente Java: user
> Home utente Java: /home/user
> Dir utente Java: /home/user/app/server
> java.specification.name: Java Platform API Specification
> java.specification.version: 1.6
> java.runtime.version: 1.6.0_22-b04
> --------- Informazioni su Derby --------
> JRE - JDBC: Java SE 6 - JDBC 4.0
> [/home/user/app/lib/derby.jar] 10.6.2.1 - (999685)
> [/home/user/app/lib/derbytools.jar] 10.6.2.1 - (999685)
> ------------------------------------------------------
> ----------------- Informazioni sulla locale -----------------
> Locale attuale:  [italiano/Italia [it_IT]]
> E' stato trovato il supporto per la locale: [it]
> 	 versione: 10.6.2.1 - (999685)
> ------------------------------------------------------
>
> If you need something to be translated, tell me.
> In ~/home/user/app/lib/ folder I have these files: derby.jar, derby.war.
> derbyclient.jar, derbyLocale_it.jar, derbynet.jar, derbyrun.jar,
> derbytools.jar.
> In the original derby installation folder, in /lib/ there are more file than
> I have in my app/lib, because I removed all the *.jar for the other
> languages (to be nerdy, i removed all derbyLocale_xy.jar where (xy != it). I
> don't think the problem it's there anyway...
>
> To anyone who is still reading and replying to this thread, thanks a lot,
> you're very kind.


Mime
View raw message