db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bhat, Avinash (NSN - IN/Bangalore)" <avinash.b...@nsn.com>
Subject RE: Problem inserting a record with derby
Date Fri, 01 Oct 2010 08:11:20 GMT
Hi We /Kristian ,
our application supports SHA 1 as a default but the default in derby is SHA 256.
I Tried changing that to the supporting algorithm
by out application. It Fine now. Working fine. Thanks for your kind information and help.
Best Regards,
Avinash V.Bhat| Nokia Siemens Networks | SPA2 |* +91 (80) 4363 2091(Direct) | * (858) 2091(VOIP)
| * : avinash.bhat@nsn.com 


From: ext Mamatha Kodigehalli Venkatesh [mailto:Mamatha.Venkatesh@ness.com] 
Sent: Friday, October 01, 2010 1:14 PM
To: Derby Discussion; derby-user-info@db.apache.org; derby-user-faq@db.apache.org
Cc: Bhat, Avinash (NSN - IN/Bangalore); kristian.waagan@oracle.com; lilywei@yahoo.com
Subject: RE: Problem inserting a record with derby

Hello all,


I too upgraded derby from to, I am getting below exception 

When I tried to insert a record into the table using a prepared statement.



java.sql.SQLException: Java exception: 'org.apache.derby.iapi.sql.execute.Result




eneratedMethod;IZZDD)Lorg/apache/derby/iapi/sql/execute/NoPutResultSet;: java.la


        at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknow

n Source)

        at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)

        at org.apache.derby.impl.jdbc.Util.javaException(Unknown Source)

        at org.apache.derby.impl.jdbc.TransactionResourceImpl.wrapInSQLException

(Unknown Source)

        at org.apache.derby.impl.jdbc.TransactionResourceImpl.handleException(Un

known Source)

        at org.apache.derby.impl.jdbc.EmbedConnection.handleException(Unknown So


        at org.apache.derby.impl.jdbc.ConnectionChild.handleException(Unknown So


        at org.apache.derby.impl.jdbc.EmbedStatement.executeStatement(Unknown So


        at org.apache.derby.impl.jdbc.EmbedPreparedStatement.executeStatement(Un

known Source)

        at org.apache.derby.impl.jdbc.EmbedPreparedStatement.executeUpdate(Unkno

wn Source)


However Iam able to insert a record into table through ij editor.







From: Lily Wei [mailto:lilywei@yahoo.com] 
Sent: Tuesday, September 21, 2010 1:49 AM
To: Derby Discussion
Cc: avinash.bhat@nsn.com
Subject: Re: Problem!


Hi Avinash:
   You can find the changes from to in here: http://wiki.apache.org/db-derby/DerbyTenSixOneRelease

   Does your application change behavior because of new features? As Kristian point out, the
trace will give us more information in turn of which part of Derby the problem occurs along
with what operation is performed to upgrade derby from to

Hope this help,



From: Kristian Waagan <kristian.waagan@oracle.com>
To: derby-user@db.apache.org
Sent: Fri, September 17, 2010 3:47:21 AM
Subject: Re: Problem!

On 17.09.10 12:11, Bhat, Avinash (NSN - IN/Bangalore) wrote:
> Hi,
> This is avinash bhat, I am facing a problem in derby upgrade. Currently I have
version installed in my system and when I tried upgrading it to my software is not
able to load it is throwing null pointer exception. But it is able to create databases for
the first time and if database already exist it says Null pointer exception.
> Can I know what is the problem which I am facing? Or do I know what major difference
that you people have made between and

Hi Avinash,

I don't know why you get this error.
Can you post the stack trace you get when hitting the problem?
( written to the console, or to derby.log )
Also, are you doing a hard upgrade (specifying upgrade=true in the connection URL), or are
you doing a soft upgrade (no special attributes in the connection URL)?

The trace may tell us in which part of Derby the problem occurs.

-- Kristian

> With regards,
> Avinash Bhat


View raw message