db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lily Wei <lily...@yahoo.com>
Subject Re: Problem!
Date Mon, 20 Sep 2010 20:18:33 GMT
Hi Avinash:
   You can find the changes from 10.5.3.0 to 10.6.1.0 in here: 
http://wiki.apache.org/db-derby/DerbyTenSixOneRelease

    Does your application change behavior because of new features? As  Kristian 
point out, the trace will give us more information in turn of  which part of 
Derby the problem occurs along with what operation is  performed to upgrade 
derby from 10.5.3.0 to 10.6.1.0.


Hope this help,
Lily



________________________________
From: Kristian Waagan <kristian.waagan@oracle.com>
To: derby-user@db.apache.org
Sent: Fri, September 17, 2010 3:47:21 AM
Subject: Re: Problem!

On 17.09.10 12:11, Bhat, Avinash (NSN - IN/Bangalore) wrote:
> 
> Hi,
> 
> This is avinash bhat, I am facing a problem in derby upgrade. Currently I have 
>10.5.0.3 version installed in my system and when I tried upgrading it to 
>10.6.0.1 my software is not able to load it is throwing null pointer exception. 
>But it is able to create databases for the first time and if database already 
>exist it says Null pointer exception.
> 
> Can I know what is the problem which I am facing? Or do I know what major 
>difference that you people have made between 10.5.0.3 and 10.6.0.1?
> 

Hi Avinash,

I don't know why you get this error.
Can you post the stack trace you get when hitting the problem?
( written to the console, or to derby.log )
Also, are you doing a hard upgrade (specifying upgrade=true in the connection 
URL), or are you doing a soft upgrade (no special attributes in the connection 
URL)?

The trace may tell us in which part of Derby the problem occurs.


Regards,
-- Kristian

> With regards,
> Avinash Bhat
> 


      
Mime
View raw message