db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Leslie Software <lesliesoftw...@yahoo.com>
Subject Re: Plug-in won't work in "Java and Report Developers" Eclipse
Date Wed, 25 Nov 2009 12:46:40 GMT
I am not sure if you found a solution to your problem - it has been a while since I kept up
to date on this list.

One possible reason for your problem is the way they have specified their plug-in's dependency
on the Derby plug-in.  When setting up a dependency between plug-ins you can specify a minimum
version, both a minimum and maximum version or no version at all for the plug-in yours depends
on.  For example in one of my plug-ins I have a dependency on the Derby plug in that looks
like this (from my plug-in's MANIFEST.MF file):
    <snip>
    Require-Bundle: <snip>
     
org.apache.derby.core,
    <snip>

This means when ever I replace the derby plug-in, regardless of what version it is, my plug-in
will try to use it.  Since I am writing an RCP application and am in total control of what
ships I find this convenient. 

Alternatively you can specify a minimum version for a dependent plug-in, like this:
    <snip>
    Require-Bundle: <snip>
     org.apache.derby.core;bundle-version="10.4.1",
    <snip>


Or you can specify both a minimum and maximum (in the example below, a specific version),
like this:
    <snip>
    Require-Bundle: <snip>
     
org.apache.derby.core;bundle-version="[10.4.1,10.4.1]",
    <snip>
 
If the plug-ins that are failing to load have a bundle-version property on their dependency
to the derby plug-in that could explain what is going on.

Ian

--
Ian Leslie - Shareware Author (mailto:lesliesoftware@yahoo.com)




----- Original Message ----
From: Alexandros Karypidis <akarypid@yahoo.gr>
To: derby-user@db.apache.org
Sent: Sat, October 31, 2009 4:26:15 AM
Subject: Plug-in won't work in "Java and Report Developers" Eclipse

Hi,

I've hit a problem which is very likely to be what was discussed in this list here:
http://old.nabble.com/Eclipse-3.5-Plugin-%28Galileo%29-works-only-partial-tt24897570.html

I have some extra information about this (most importantly a consistent way to reproduce):

When using the "Eclipse IDE for Java and Report Developers" installation, ANY derby core plug-in
downloaded from the Apache Derby web site is NOT detected. This edition (btw it is an official
distribution from eclipse.org) is essentially the JEE edition together with the BIRT reporting
plug-ins; You can get it from the official Eclipse downloads site:

http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/galileo/SR1/eclipse-reporting-galileo-SR1-win32.zip

Now, compared to the pure JEE edition (where everything works properly), the BIRT edition
has the reporting plug-ins and they also show some lovin for Derby as they include a version
of the core plug-in: org.apache.derby.core_10.3.1.4 plugin.

So, I was trying to replace it with a newer version by deleting what BIRT came with and adding
the core plug-in downloaded from the Apache Derby site (tried 10.3.3.0, 10.4.2.0 and 10.5.3.0).
No matter what I do, the new plugin is not detected running "eclipse -clean -debug" does not
provide any relevant information (some birt plug-ins fail to resolve due to missing the derby
core, but there is nothing about the derby core plugin itself). It appears as though the bundle
is silently ignored and then causes the installation of a couple of other bundles that depend
on it to fail.

I'm about to head to the BIRT newsgroup to discuss this (at the very least they should stop
distributing 10.3.1.4 which has known data corruption issues), but I'm hoping to gather some
more information here first (I can point them to this thread when I bring it up there).

Can somebody knowledgeable download the file above and have a look at the plugins\org.apache.derby.core_10.3.1.4
folder to see what they distribute (as far as I can see, main differences are that the network
libraries are missing and the bundle is sealed).

Hopefully, one come up with a suggestion regarding why newer versions of the derby core are
not picked up. It's probably something that they do, but I just want an educated opinion before
I head over there to complain.

Thanks


      __________________________________________________________________
Reclaim your name @ymail.com or @rocketmail.com. Get your new email address now! Go to http://ca.promos.yahoo.com/jacko/

Mime
View raw message