db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject Re: Using Derby to access Cloudscape DB
Date Wed, 04 Nov 2009 20:12:32 GMT
Hi Mike,

The J2EE SDK for version 1.3_01 claims that it contains a copy of 
Cloudscape 4.0: http://java.sun.com/j2ee/sdk_1.3/1.3_01/ That might help 
you, provided that your Cloudscape database is at rev 4.0 or earlier.

Hope this helps,
-Rick

mjs1138 wrote:
> Hi.  I'm hoping someone here can help me or at least point me in the right /
> any direction.
>
> I've been asked to retrieve data from an old java app that was developed
> using cloudscape (CS).  I have never used cloudscape or derby.  The reading
> I've done tells me that CS has been migrated to derby.
>
> I started w/ the derby tutorial and got it to work using ij from a dos cmd
> window.  I then tried to CONNECT to the other DB and received this message:
>
>   ERROR XJ040: Failed to start database 'patientdb', see the next exception
> for details.
>   ERROR XSLAC: Database at C:\Users\Mike\DERBYTUTOR\patientdb have
> incompatible format with the current version of software, it may have been
> created by or upgraded by a later version.
>
> I've searched for a migration process but haven’t been able to find one. 
> Any thought or help w/ direction will be greatly appreciated.
>
> Thanks --- Mike
>
>
>
>   


Mime
View raw message