db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Hill <Thomas.K.H...@t-online.de>
Subject Re: ERROR 42X51 class not found
Date Sat, 24 Oct 2009 15:25:37 GMT
Hi,

what I have done now is
1) opened up a root terminal session on the server
2) checked CLASSPATH with echo $CLASSPATH command -> emtpy
3) defined the CLASSPATH=/var/lib/derby/db-derby-10.5.3.0-bin/lib/
4) exported the CLASSPATH
5) checked CLASSPATH setting again and now the path was returned
6) ran sysinfo again and saw the path was added at the end, as you can see here
in the new sysinfo output (see last entry)
Java classpath:  /var/lib/derby/db-derby-10.5.3.0-bin/lib/derby.jar
:/var/lib/derby/db-derby-10.5.3.0-bin/lib/derbynet.jar
:/var/lib/derby/db-derby-10.5.3.0-bin/lib/derbytools.jar
:/var/lib/derby/db-derby-10.5.3.0-bin/lib/derbyclient.jar
:/var/lib/derby/db-derby-10.5.3.0-bin/lib/
7) opened a second root terminal session and copied my folder derbyPk and the
all files included from my windows machine to the server as
:/var/lib/derby/db-derby-10.5.3.0-bin/lib/derbyPk
8) switched back to my first root terminal session (in which classpath variable
was defined and then
8) started the network server in the same terminal session 
9) tried to execute the DDL again against the server

=> unfortunately with the same result - still getting error 42X51



Mime
View raw message