Hi Brian,

Shutdown on a frozen database will hang,

Are you doing a shutdown, ctrl+c before copying the DB for replication?

Can you please avoid the shutdown, ctrl+c step?

Have you already seen this http://wiki.apache.org/db-derby/ReplicationWriteup ?

You will find step by step instructions to get replication started there!

Narayanan

On 04/08/09 07:53, Brian Spindler wrote:
I've tried both:

connect 'jdbc:derby:<db>;shutdown=true';

and

exit; 

both seem to simply hang and I'm forced to do Ctrl+C to get back my command prompt.  Does that sound right? 

regardless; both result in the same error.


-----Original Message-----
From: Dag H. Wanvik [mailto:Dag.Wanvik@Sun.COM]
Sent: Tue 4/7/2009 4:57 PM
To: Derby Discussion
Subject: Re: master and slave are not in synch for replicated database
 
Brian Spindler <bspindler@netuitive.com> writes:

  
Guys/Gals,

 

I have taken the following procedure:

 

1.       Using ij logged into my database

2.       Run CALL SYSCS_UTIL.SYSCS_FREEZE_DATABASE();
    

I saw in another thread you use embedded. Did you do a shutdown at
this point?
E.g. connect 'jdbc:derby:<db>;shutdown=true'

  
3.       Exit ij

4.       Copy database to slave

5.       Start slave

6.       Start master.

 

Then I get this error: 

 

Caused by: ERROR XRE05: The log files on the master and slave are not in
synch for replicated database 'foo'. The master log instant is 1:104173,
whereas the slave log instant is 1:103957. This is FATAL for replication
- replication will be stopped.

                

 

I thought by freezing/copying etc... they would be in synch?