db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kent Spaulding <k...@iotabits.com>
Subject Derby 10.4.2 and eclipse 3.4.1 (Ganymede)
Date Fri, 30 Jan 2009 19:47:03 GMT
Hi,

I've been trying to get Derby working with eclipse 3.4.1, aka Ganymede.

I followed the instructions on the derby site, unzipping and copying  
the files to the ECLIPSE_HOME/plugins dir:

plugins/org.apache.derby.core_10.4.2
plugins/org.apache.derby.ui_1.1.2
plugins/org.apache.derby.plugin.doc_1.1.2

For this version of eclipse, there is already a Derby core in the  
plugins dir:

org.apache.derby.core_10.3.1.4:
META-INF    about_files    derby.jar
about.html    asl-v20.txt    plugin.xml

The eclipse update manager does not report it as installed, oddly  
enough.  However, it does get picked up.

When I restart eclipse, the Derby UI and docs are available, but it is  
picking up the 10.3.1.4 version of the core, because only derby.jar is  
available.

I know this because when I run ij from eclipse I get:

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/ 
derby/tools/ij

on the console window.

That tool is in derbytools.jar, which is not in the 10.3.1.4 core  
plugin dir.

If I delete the org.apache.derby.core_10.3.1.4 dir, and restart,  
10.4.2 is still not picked up.

Something is wrong with the plugin for 10.4.2 for eclipse 3.4.1.

Has anyone seen this before?  Got a fix?

Thanks,
--Kent


Mime
View raw message