db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephan van Loendersloot (LIST)" <step...@republika.nl>
Subject Re: Tomcat derby JSP "java.sql.SQLException: No suitable driver"
Date Tue, 09 Dec 2008 02:36:00 GMT
Emmanuel Cecchet wrote:
>
>>> Just to check, which JVM are you using? What is the output of 'java 
>>> -version'?
>>> Did you make sure that both Tomcat and Derby where using the same JVM?
>>>
>>
>> This seems to be irrelevant.
>
> Well, if he uses a default Kaffee or gij, there are many classloader 
> issues with Tomcat.
> I already had several users having problems with Sequoia and Derby 
> because of the wrong JVM.
>
> Emmanuel
>

Hi Emmanuel,

Mike told us he uses a Mac, so I think there's little chance that he 
uses a custom installed JVM on his box and besides, Tomcat has to read 
the configuration files before it can even know what driver to use. If 
it can't find the required class, an error message like 'Cannot load 
JDBC driver class 'org.apache.derby.jdbc.ClientDriver'' would be issued.

Then again, your right that it's better to actually know what JVM you're 
using, even if it's just to rule out that possibillity.


Regards,

    Stephan.

Mime
View raw message