db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: JDK 1.4 support?
Date Wed, 26 Nov 2008 18:57:30 GMT
"Bernt M. Johnsen" <Bernt.Johnsen@Sun.COM> writes:

>>>>>>>>>>>>> pedrofaundezgon@terra.es wrote (2008-11-26
13:30:52):
>> So, that means that either I should install an unsupported JDK 1.4 
>> from SUN or a JDK 1.4 from IBM that I can not install because of IBM 
>> JDK licensing issues.
>
> Yes, and the Sun JDK 1.4 is still downloadable. As far as I
> understand, the IBM JDK is freely available, but you have to
> register. Correct me if I'm wrong.

After its being EOLed, registration is needed for Sun's JDK as well. The
JRE (which is the only part of 1.4 you need) is still available with no
registration, though. http://java.sun.com/j2se/1.4.2/download.html

>> I hope you understand that making it so hard for new developers will 
>> not help.
>
> I understand that it's a nuisance, but it have to be that way until
> the Derby community decides to not support 1.4

No, it doesn't have to be that way. :)

It is possible to make changes to the build system so that it builds jar
files that can be used on JRE 1.4 without requiring the 1.4 libraries at
compile-time. Please file a JIRA issue at
https://issues.apache.org/jira/browse/DERBY if you'd like to see it
fixed.

-- 
Knut Anders

Mime
View raw message