db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dag.Wan...@Sun.COM (Dag H. Wanvik)
Subject Re: JDK 1.4 support?
Date Tue, 25 Nov 2008 22:39:57 GMT
I think we just need one JDK (1.6), but we do need JREs for 1.4 and
1.5 to compile Derby successfully. I am not sure BUILDING.txt reflects
this, though. I agree it is a bit cumbersome for the would-be
developer to have to download all that. I think we need the 1.4 JRE to
make sure we maintain compatibility with JME CDC 1.1 Foundation
profile (Constrained Device Configuration). Presently, there is a
single build (one jar file version only) for embedded Derby.

It would have been nice if new developers didn't have to worry about
that...

Thanks,
Dag

Mime
View raw message