db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren" <m.v.lunte...@gmail.com>
Subject Re: JDK 1.4 support?
Date Wed, 26 Nov 2008 19:46:30 GMT
On Wed, Nov 26, 2008 at 10:57 AM, Knut Anders Hatlen
<Knut.Hatlen@sun.com> wrote:
> "Bernt M. Johnsen" <Bernt.Johnsen@Sun.COM> writes:
>>
>> I understand that it's a nuisance, but it have to be that way until
>> the Derby community decides to not support 1.4
>
> No, it doesn't have to be that way. :)
>
> It is possible to make changes to the build system so that it builds jar
> files that can be used on JRE 1.4 without requiring the 1.4 libraries at
> compile-time. Please file a JIRA issue at
> https://issues.apache.org/jira/browse/DERBY if you'd like to see it
> fixed.
>
> --
> Knut Anders
>

It's an issue that has to get addressed(...eventually)...so thanks for
bringing it up. Note by the way: Active participation is always
appreciated. ("fry your own fish").
I think though that this would be a change for trunk only, I don't
think it should get backported.

And yes, this should be a derby-dev item...

Myrna

Mime
View raw message