db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "pedrofaundezgon@terra.es" <pedrofaundez...@terra.es>
Subject Re: JDK 1.4 support?
Date Tue, 25 Nov 2008 18:32:57 GMT
Bryan Pendleton wrote:
>> I think support of compilation against JDK 1.4 should be removed  
>> otherwise no developers would be able to work on it.
> It seems like this is more a discussion for the *developers* list
> than the *users* list, since it only applies to people trying to
> build Derby from source, right?
> So we should probably move it to the derby-dev list.
> Is your current problem that you are having trouble getting
> a copy of the 1.4 JDK? I think you have to go to a different
> location on the download site, but I believe it is still available.
> Or are you simply raising a concern for the future, about when
> Derby should consider dropping support for JDK 1.4?

Yes, I am raising a concern about "should already be done" drop 
support for JDK 1.4.
At least, if you do not jump on 1.5 new features, just do not require 
a JDK 1.4 for compilation since many people do not want to use 
unsupported not even for development.

Requiring an unmaintained JDK just creates a problem for developers.

Ahora también puedes acceder a tu correo Terra desde el móvil.
Infórmate pinchando aquí.

View raw message