Hello All,
I noticed I derby.jar is an OSGi bundle and so I installed it in my OSGi container (Knopflerfish 2.0.5) running on IBM J9 PP1.1
I included the required jdbc.jar (JSR169) in the bootpath of the J9 jvm. I can install the bundle no problems. When I try and start the bundle I get:
java.lang.NoClassDefFoundError: java.sql.Driver
From reading this page on the wiki http://wiki.apache.org/db-derby/JavaMESupport?highlight=(j2me)
I know java.sql.Driver does not exist in JSR169.
Hence how do I tell the derby bundle not to use java.sql.Driver and use instead javax.sql.DataSource
Any help would be appreciated.
Many Thanks