db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ScottDerrick <sc...@tnstaafl.net>
Subject Oracle TopLink Essentials requires Derby ClientDriver?
Date Thu, 11 Sep 2008 21:38:21 GMT

When you use the Netbeans IDE to generate a database connected application it
uses Toplink.

I am using Derby as the database and the persistance configuration is setup
to use the ClientDriver.

<property name="toplink.jdbc.driver"
value="org.apache.derby.jdbc.ClientDriver"/>

I need to use the embedded driver so I changed the config to

<property name="toplink.jdbc.driver"
value="org.apache.derby.jdbc.EmbeddedDriver"/>

and added the derby.jar to the run time library configuration.

But I now get this error?

Internal Exception: java.sql.SQLException: No suitable driver found for
jdbc:derby://localhost:1527/SBD

Can Toplink be configured to use the embedded driver?

Scott
-- 
View this message in context: http://www.nabble.com/Oracle-TopLink-Essentials-requires-Derby-ClientDriver--tp19445337p19445337.html
Sent from the Apache Derby Users mailing list archive at Nabble.com.


Mime
View raw message