db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Embretsen <John.Embret...@Sun.COM>
Subject Re: Derby on 1.3 VM
Date Wed, 13 Aug 2008 07:30:51 GMT
Jim Duffy wrote:
> We have a Palm OS Java Conduit that unfortunately is limited to running only
> on a 1.3 VM. We need this component to access our main Derby database to
> read some records.
> 
> We are using the latest version of Derby and wanted to know if the source
> code could be compiled to work with the 1.3 VM.
> 
> Does anyone know if this is possible?
> 
> From the "building" documentation of the source code, it seems to suggest
> that the minimum VM for derby is 1.4.x.
> 
> Any suggestions?

It is correct that the current minimum VM level for Derby is 1.4.

>>From the first Derby 10.3 version and onwards, Derby developers startedto remove Java
1.3 dependencies in Derby, to simplify maintenance and to
be able to take better advantage of newer Java features (as it was
decided that 1.3 was no longer going to be supported).

See for example:
https://issues.apache.org/jira/browse/DERBY-1982

The last Derby version to support Java 1.3 was version 10.2.2.0, which
you can find on Derby's download page.

Note that the latest Derby versions (embedded only) also run on small
devices through Java ME (CDC/Foundation 1.1).
http://wiki.apache.org/db-derby/JavaMESupport


-- 
John





Mime
View raw message