db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kai Ponte <...@perfectreign.com>
Subject Re: Can't change column name, or drop database
Date Mon, 14 Apr 2008 12:21:45 GMT
On Saturday 12 April 2008 08:34:20 pm A. Rick Anderson wrote:
> I have not been able to change the name of a column in an embedded
> database.  When I try, it gives me a false error about the word "column"
> appearing in the 8th column.

I have yet to be able to change colum names. I tend to drop the database....
>
> So I tried to drop the table.  Unfortunately, there is a long cascade of
> dependencies.  

...which I can do because I never let the RDBMS create my dependencies.  Not a 
good idea in practice. 

> So I  tried to  drop the entire schema and re-create it 
> from scratch.   Then it tells me that there is an <EOF> in the fifteen
> column of line one (which is in the middle of my schema name).

What are you using to create the schema? Eclipse? Some text editor?


-- 
kai
www.filesite.org || www.4thedadz.com || www.perfectreign.com
remember - a turn signal is a statement, not a request

Mime
View raw message