db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Narayanan <V.Naraya...@Sun.COM>
Subject Re: Can't change column name, or drop database
Date Mon, 14 Apr 2008 06:54:12 GMT
A. Rick Anderson wrote:
> I have not been able to change the name of a column in an embedded 
> database.  When I try, it gives me a false error about the word 
> "column" appearing in the 8th column.
> So I tried to drop the table.  Unfortunately, there is a long cascade 
> of dependencies.  So I  tried to  drop the entire schema and re-create 
> it from scratch.   Then it tells me that there is an <EOF> in the 
> fifteen column of line one (which is in the middle of my schema name).
>
> I'm running out of options here.
> The IDE is MyEclipse 6.01 (which, just as an FYI, does a rather poor 
> job of ORM comparatively.)
>
> -- A. Rick Anderson
>
Hi Rick,

If you had used the rename column statement as described in this link

http://db.apache.org/derby/docs/dev/ref/rrefsqljrenamecolumnstatement.html

would it be please possible for you to mention the exact error you 
encountered?
copy pasting the SQL you used and the error message would be useful.

The problem that you seem to encounter when you are trying to drop the 
schema is I think
because you are not using the RESTRICT keyword.

Here is the drop schema command copy pasted from here

http://db.apache.org/derby/docs/dev/ref/rrefsqlj31648.html

DROP SCHEMA schemaName RESTRICT

The RESTRICT keyword enforces the rule that no objects can be defined in 
the specified schema for the schema to be deleted from the database. The 
RESTRICT keyword is required

Narayanan

Mime
View raw message