db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Schomisch, Siegfried" <siegfried.schomi...@gesis.org>
Subject Using derby.jar (Derby-version-10.3.2.1) in Linux and Mac (java-1.5.0-version)
Date Wed, 23 Jan 2008 10:11:24 GMT
Sorry, I don't know the technical way (in Newsgroups-website:
"gmane.comp.apache.db.derby.user"?) to reply directly to the answer of
'John Embretsen' to my subject from 2008-01-22. So I write a new email
to the same subject. 

John Embretsen wrote:
> Not sure I understand what the problem is...
> Did you build Derby from source?
I downloaded "db-derby-10.3.2.1-bin.zip" from "Apache Derby 10.3.2.1
Release" (s. http://db.apache.org/derby/releases/release-10.3.2.1.cgi )
and use then 'derby.jar' from the unpacked "db-derby-10.3.2.1-bin.zip".
I think this downloaded zip-file is ok or not?

The mentioned operatings systems (Mac OS and Linux-'Debian Etch' in a
VMWare, http://www.visoracle.com/download/debian/ downloaded there
'vmware-debian-etch-40r0.zip') have both Java 1.5.0.

I have also informed 'install4j' (i.e.
http://www.ej-technologies.com/index.html ) about the described problem
in my email from 2008-01-22. When I was writing/copying 'derby.jar' to
Linux-'Debian Etch' in a VMWare, I got the error message in
Linux-'Debian Etch': "Corrupted pack file: magic/ver=CAFED00D/160.1
should be CAFED00D/150.7". When I took as a test 'derby.jar' from an
earlier Derby-release download e.g. 10.1.3.1 (Jun 30, 2006 / SVN 417277)
the writing/copying of this 'derby.jar' in Linux-Debian Etch worked then
successfully.

On Windows xp my installation download with 'install4j' works
successfully, i.e. writing/copying 'derby.jar' makes no problem. But on
windows xp I have Java 1.6.0.  

Do you have any idea how to solve this problem? Thanks in advance.

Siegfried







 

Mime
View raw message