db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Embretsen <John.Embret...@Sun.COM>
Subject Re: Using derby.jar (Derby-version-10.3.2.1) in Linux and Mac (java-1.5.0-version)
Date Thu, 24 Jan 2008 08:28:23 GMT
Schomisch, Siegfried wrote:
> Sorry, I don't know the technical way (in Newsgroups-website:
> "gmane.comp.apache.db.derby.user"?) to reply directly to the answer of
> 'John Embretsen' to my subject from 2008-01-22. So I write a new email
> to the same subject. 

That's OK. You may explicitly subscribe to the mailing list to participate in
current/future threads. I know this works through www.nabble.com as well.

> John Embretsen wrote:
>> Not sure I understand what the problem is...
>> Did you build Derby from source?
> I downloaded "db-derby-10.3.2.1-bin.zip" from "Apache Derby 10.3.2.1
> Release" (s. http://db.apache.org/derby/releases/release-10.3.2.1.cgi )
> and use then 'derby.jar' from the unpacked "db-derby-10.3.2.1-bin.zip".
> I think this downloaded zip-file is ok or not?

Yes, that should absolutely be OK.

> The mentioned operatings systems (Mac OS and Linux-'Debian Etch' in a
> VMWare, http://www.visoracle.com/download/debian/ downloaded there
> 'vmware-debian-etch-40r0.zip') have both Java 1.5.0.
> 
> I have also informed 'install4j' (i.e.
> http://www.ej-technologies.com/index.html ) about the described problem
> in my email from 2008-01-22. When I was writing/copying 'derby.jar' to
> Linux-'Debian Etch' in a VMWare, I got the error message in
> Linux-'Debian Etch': "Corrupted pack file: magic/ver=CAFED00D/160.1
> should be CAFED00D/150.7". When I took as a test 'derby.jar' from an
> earlier Derby-release download e.g. 10.1.3.1 (Jun 30, 2006 / SVN 417277)
> the writing/copying of this 'derby.jar' in Linux-Debian Etch worked then
> successfully.
> 
> On Windows xp my installation download with 'install4j' works
> successfully, i.e. writing/copying 'derby.jar' makes no problem. But on
> windows xp I have Java 1.6.0.  
> 
> Do you have any idea how to solve this problem? Thanks in advance.

No idea right now. It may be that install4j is somehow repackaging the jar file
in an incompatible way. The magic number issue seems to be, as you have
indicated, that the tool trying to "use" the jar expects to see 150.7 (java
1.5), but gets 160.1 (java 1.6) instead.

At least, we have run numerous tests using JVMs older than 1.6.0 against
10.3.2.1 without problems. We haven't used Debian or VMWare much though, but I
doubt that the OS/platform itself has much to do with this.

The error you reported occurred while running the installer generated by
install4j, right? On which platform (OS) did you actually create this installer?
Is JDK 6 available on that machine?

The only possibly related difference I have noticed with regards to the manifest
file (META-INF/MANIFEST.MF) of the derby.jar file in 10.3.x.y versions compared
to 10.2.x.y and previous versions is:

10.2.2.0: Ant-Version: Apache Ant 1.6.2
10.2.2.0: Created-By: 1.4.2_07-b05 (Sun Microsystems Inc.)

10.3.2.1: Ant-Version: Apache Ant 1.7.0
10.3.2.1: Created-By: 1.6.0_01-b06 (Sun Microsystems Inc.)

Does anyone know if this could have significance in certain scenarios, such as
an install4j installation?


-- 
John



Mime
View raw message