db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Embretsen <John.Embret...@Sun.COM>
Subject Re: Using derby.jar (Derby-version-10.3.2.1) in Linux and Mac (java-1.5.0-version)
Date Wed, 23 Jan 2008 07:57:17 GMT
Siegfried Schomisch wrote:
> Hi,
> 
> Its not possible to use (i.e. writing derby.jar file by an installer
> "install4j" to a destination directory on Linux or Mac OS, which have
> both jre 1.5.0 on their OS) derby.jar from
> "Derby_Apache_10.3.2.1"-version, where derby.jar was compiled with
> java-version-1.6.0
> 
> What is the reason for that problem?
> 
> Thanks for answering in advance

Not sure I understand what the problem is...
Did you build Derby from source? In a 10.3.2.1 binary distribution, or if you 
build it yourself and follow all the instructions in BUILDING.txt, derby.jar is 
compiled with both j2sdk 1.4.2 and JDK 6, and will work on both 1.4.2, 1.5.0 and 
1.6.0, as well as Java ME.

I'm not familiar with how install4j works, but merely copying derby.jar from one 
location to another should work on all platforms, barring any user or file 
permission issues on your end.


-- 
John


Mime
View raw message