db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael J. Vinca" <michaelvi...@gmail.com>
Subject Re: Why might embedded Derby not preserve state?
Date Fri, 04 Jan 2008 02:41:29 GMT
Where are you storing your Derby database? Is it being made in a  
temporary directory of Tomcat?

- OR -

Are you specifying to create the database when you startup, thereby  
overwriting what you previously had?

Just some thoughts...

~Mike Vinca
_______________________________________________
Signature of exoflare:
Trying to stop AIDS by handing out condoms is like trying to end  
murder by handing out bullet-proof vests.



On Jan 3, 2008, at 7:13 PM, Brian Sayatovic wrote:

> I'm trying to run XWiki Enterprise with embedded Derby (via XWiki's  
> use of Hibernate) under Tomcat 5.  I first tried this a couple of  
> months ago, and have just tried again using the latest release of  
> Derby ( 10.3.2.1).
>
> I can start the application just fine, add content, browse it,  
> etc.  When I then shut down Tomcat and start it again, all of my  
> content is gone.
>
> I doubt it is a global flaw in XWiki because I've got it working  
> fine with another DB.  I'm also fairly certain its not a blatant  
> problem in Derby since it would be so fatal.
>
> Instead, I suspect its an unexpected interaction.  So what sort of  
> things might be causing this?  Any ideas on what I could look for?
>
> Regards,
> Brian.


Mime
View raw message