db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dag.Wan...@Sun.COM (Dag H. Wanvik)
Subject Re: compiling Derby under java 1.6
Date Wed, 19 Sep 2007 18:36:26 GMT
Mikhail Umorin <mikeumo@sbcglobal.net> writes:

As for the IncompatibleClassChangeError, I don't know why you get this
here, you may want to print out any nested exceptions you get, which
might provide more information on the cause.

Also, do you see anything in derby.log on the server?

As for compiling Derby with JDK 1.6:

I think i use a plain "xalan.jar", which in addition to xalan-j2-2.7.0
contains some supporting packages, perhaps that is why you have an
compile time issue with xpath and serializer. 
(see http://xml.apache.org/xalan-j/downloads.html).

As for the problem with the the abstract method
(EmbedDatabaseMetaData), this line in ant.properties is wrong:


It should point to the JDK 1.4, not to JDK 1.6, even if you use the
1.6 compiler. (Derby needs to compile some of the sources with a
JDK1.4 source level and runtime, in order for the resulting product to
be runnable on multiple platform versions).


View raw message