db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paulo Jesus" <paulsch...@gmail.com>
Subject Re: Derby 10.3.1.4 compiling problems
Date Fri, 14 Sep 2007 18:10:42 GMT
2007/9/14, Kathey Marsden <kmarsdenderby@sbcglobal.net>:
> Paulo Jesus wrote:
> > The problem seems to start after, or inside, the first run of "ant "...
> >
> >
> Derby does not have a dependency based build. I always do an ant clobber
> between builds.  If it builds cleanly after an "ant clobber" then that
> is good.
>
> The problem you reported with the scripts is likely because you are
> using  $DERBY_HOME/classes instead of jars. I don't know when/why
> network server was changed to require jars, but to run it these days I
> have to remove the old jars and build the jars, "ant buildjars" after
> ant all and of course change my CLASSPATH to point to the jar location.
> So short story...
>
> ant clobber
> ant all
> rm -rf jars/insane/*
> ant buildjars
>

Compiling this ways it works. Is like doing "ant clean" instead "ant clobber".
The second run of "ant "  or "ant all"   fails with the error i talked before.
This way I have trouble watching if there is errors on compiling,
because i can't run "ant "  again before doing a clean. This means
that i have many lines to analyze. Should be a better way to do this.

I have also errors generating javadoc of engine. It cat be related to
jars configuration. I will see this later.

Thanks


> change your classpath to point to the jars/insane location.
>
> Kathey
>
>
>

Mime
View raw message