db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Pendleton <bpendle...@amberpoint.com>
Subject Re: Use of AUTHORIZATION
Date Thu, 23 Aug 2007 01:22:13 GMT
> Error code -1, SQL state XCL47: Use of 'AUTHORIZATION' requires database 
> to be upgraded from version 10.1 to version 10.2 or later.

The GRANT/REVOKE family of features were introduced in Derby 10.2.

To upgrade your 10.1-version database to 10.2, pass upgrade=true
on your connection URL when connecting to the database.

Make a backup of the database first, as a precautionary measure.

Here's some nice info on the upgrade process:
http://davidvancouvering.blogspot.com/2007/08/how-to-upgrade-derbyjava-db-database.html

thanks,

bryan


Mime
View raw message