db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Baker <John.Ba...@Sun.COM>
Subject Use of AUTHORIZATION
Date Thu, 23 Aug 2007 01:12:17 GMT

I'm using version 10.2.2

I want database vir to use schema, vir

CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY(
    'derby.user.vir', 'vir');
CREATE SCHEMA vir AUTHORIZATION vir;

when I pass this url, jdbc://localhost:1527/vir;create=true
the result is
Error code -1, SQL state XCL47: Use of 'AUTHORIZATION' requires database 
to be upgraded from version 10.1 to version 10.2 or later.

Any ideas?

If I don't set AUTHORIZATION then it appears that system schemas are 
only available for database vir

Thanks,
John




Mime
View raw message