db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oystein Grovlen - Sun Norway <Oystein.Grov...@Sun.COM>
Subject Re: Problem connecting to Derby
Date Fri, 17 Aug 2007 07:26:30 GMT
John Baker wrote:
> 
> Would someone kindly have some suggestions for this
> user
> 
> http://www.nabble.com/%27Unsupported-upgrade-from-10.1-to-10.2-beta%27---Cannot-Connect-to-Demo-Databases-tf4256082.html#a12179867

> 
> 
> Thank you
> John

The error message about upgrade from 10.1 to 10.2 beta indicates that 
the user is trying to access a database created with an official release 
(10.1) with alpha/beta software.  This is by default prevented in order 
to avoid that a production database is accidentally corrupted by 
unstable software.  It is possible to allow this by setting the property 
derby.database.allowPreReleaseUpgrade.  However,10.2.0.3 is an alpha 
release that came with an early access release of JDK 6 (build 89), and 
I think the user should consider to use a newer version of Derby (and 
the JDK?).

Hope this helps,

Øystein


Mime
View raw message