db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jitesh Mehta <jitesh...@gmail.com>
Subject Upgrading from 10.2 beta to 10.3.1.4 official relaease
Date Tue, 21 Aug 2007 14:06:34 GMT

Hi,

I have a Database created using the 10.2.1000000.430903 release of Derby.
 
I would like to fully upgrade this database to the latest derby official
release 10.3.1.4.

When i boot the database with upgrade=true following exception is thrown:

Caused by: java.sql.SQLException: Database at
F:\freshCheckOut\butterfly\installer\samples\picApp\tests\picApp_test_db is
at version 10.2 beta. Beta databases cannot be upgraded,
	at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown
Source)
	at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
	at org.apache.derby.impl.jdbc.EmbedConnection.bootDatabase(Unknown
Source)... 34 more
	
Is there anyway this upgrade from this beta release ?	
-- 
View this message in context: http://www.nabble.com/Upgrading-from-10.2-beta-to-10.3.1.4-official-relaease-tf4305387.html#a12255263
Sent from the Apache Derby Users mailing list archive at Nabble.com.


Mime
View raw message