db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hiram Chirino <hi...@hiramchirino.com>
Subject RE: Problems with Derby 10.2.2.0
Date Tue, 17 Jul 2007 00:01:41 GMT

Hi,

I would recommend you use the activemq-core.jar file instead since that
version of the jar file does not include the dependencies like derby.

Regards,
Hiram


Andrew Norman-3 wrote:
> 
> We have found the problem, we think. The ActiveMQ project uses derby and
> contains the contents of derby.jar in it's activemq.jar file.
> 
> -----Original Message-----
> From: John.Embretsen@Sun.COM [mailto:John.Embretsen@Sun.COM] 
> Sent: 12 April 2007 12:29
> To: Derby Discussion
> Subject: Re: Problems with Derby 10.2.2.0
> 
> Andrew Norman wrote:
>> I have a series of unit tests for our application. Due to issues with 
>> the metadata, I have upgraded to the latest official release
> (10.2.2.0) 
>> and have started getting the following error message appearing in my
> tests.
>> 
>> Caused by: java.lang.SecurityException: sealing violation: package 
>> org.apache.derby.iapi.services.crypto is sealed
> 
> [snip]
> 
>> Any ideas on what I should look at.
> 
> Such sealing violations usually happen when classes in the same Java
> package are 
> attempted loaded from different sources (jar files). Please double check
> that 
> you don't have multiple versions of the same jar files in your
> classpath, 
> especially multiple derby.jar files.
> 
> 
> -- 
> John
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Problems-with-Derby-10.2.2.0-tf3564887.html#a11640560
Sent from the Apache Derby Users mailing list archive at Nabble.com.


Mime
View raw message