db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "A. Rick Anderson" <ar...@pobox.com>
Subject Re: Can't run the Eclipse plug-in labs
Date Thu, 15 Feb 2007 22:12:57 GMT
Bryan Pendleton wrote:
>> 'jdbc:derby:net://localhost:1527/jayDB;create=true;user=APP;password=APP;'; 
> Try taking the "net:" out. Having "net:" in there means to use
> the IBM DB2 JDBC driver, also called the "JCC" driver. The Derby JDBC
> driver just uses the prefix jdbc:derby:, so just say jdbc:derby://...

Yeah, I saw this comment when I was googling.  However, it is not clear 
to me where and how would I "take out the 'net'" from the URL?  I, 
personally, am not creating, nor invoking, the connection URL directly. 
  I am calling ij from Eclipse via the plug-in.  I have not been able to 
locate where the URL is being defined in the ij.bat or the 
derby_common.bat files that presumably the Eclipse plug-in is calling. 
The only files where I can find that this string is found is in the 
administration manuals.

What I am trying to do is follow the lab that comes with the Eclipse 
plugin.  After installing, you are supposed to invoke 'ij' on 
jay_tables.sql script using the menu option "Apache Derby->Run SQL 
script using 'ij'".  This is where I get the error message.

If it happens to me, in this context, then presumably, everyone that has 
ever tried to follow the lab for the eclipse plugin would have the same 
error message.

-- 
A. Rick Anderson


Mime
View raw message