db-derby-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manjula G Kutty <manjula.ku...@gmail.com>
Subject Re: does derby provide SQL access management (grant and revoke permission)
Date Fri, 02 Feb 2007 00:39:10 GMT
legolas wood wrote:

> Manjula G Kutty wrote:
>
>> legolas wood wrote:
>>
>>> Hi
>>> Thank you for reading my post.
>>> Does derby support permission management for users ?
>>> for example can i define some users and then grant them some 
>>> permission?
>>>
>>> Thanks
>>>
>> Yes , The latest Release 10.2 supports SQL Authorization. You can get 
>> more information regarding this in the latest manuals.
>>
>> Some of them are
>>
>> http://db.apache.org/derby/docs/10.2/ref/
>> http://db.apache.org/derby/docs/10.2/devguide/
>>
>> Thanks
>> Manjula
>>
> Thank you for reply.
> I tried and create a derby.properties file and put it bin folder of 
> derby (it is derby home)
> I have derby.database.sqlAuthorization=true inside the 
> derby.properties file but i can not use grant and revoke commands.
> here is my steps :
> -connect to a none existance database (I forced the server to create 
> the database by using create=true)
> -create a table inside the database
> -grant some permission to another user using
>          *grant all on table2 to user2
> *
>
> what i get as an error is like :
> ERROR 42Z60: GRANT not allowed unless database property 
> derby.database.sqlAuthorization has value 'TRUE'.
>
> even i tried to set the variable by executing an sql command showed in 
> manual but it does not helps and error stayed the same.
> here is sql statement that i execute using IJ
>
>**CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY(
>    'derby.database.sqlAuthorization', 'true');
>
>can some one help ?
>**
>
>
>
First thing , you have to make sure that the derby.properties is getting 
read. Also for granting all previleges the correct statement is
grant ALL PRIVILEGES on <table name>  to <user name>;

Please don't forget that while giving the table name you have to prefix 
it with the schema name.
example: grant ALL PRIVILEGES on mkutty.t to user1; where t1 is the 
table name and mkutty is the schema name I used.

Please post if  you are still getting the error.

Thanks
Manjula

Mime
View raw message